Lab 1.23 Ngelab ke-1 ( IP Address,DHCP,Routing Statik ) Cisco menggunakan Netmiko Python Konfigurasi External

Haloo guys 😀 Selamat sore, Kali ini saya akan membagikan hasil lab yang saya kerjakan saat ini. Saya akan menjelaskan dengan mengunakan Netmiko Python Konfigurasi eksternal.

Langsung aja lihat gambar dibawah ini yah guys 😀

 Bagaimana cara agar PC1 dengan PC2 yang beda network bisa saling terhubung ?? mungkin kali jawab dengan dirouting statik itu cara yang paling sederhananya. Yep,kali ini saya akan menggunakan Routing Statik untuk menghubungkan keduanya guys :D, tapi kali ini saya menggunakan Script Netmiko Python jadi tidak perlu masuk lagi ke terminal Routernya untuk konfigurasinya.

Seperti biasanya, Pertama jangan lupa aktifkan SSH pada cisco, Karena Netmiko Python mengunakan SSH untuk berkomunikasinya. Untuk Tutorial SSH cisco bisa cek Disini

Dan Jangan lupa untuk menambahkan Modul Netmiko pada Python anda, Bisa cek Disini 

Oke langsung menuju ke KTP 😛

coba cek gambar dibawah ini :


Seperti gambar diatas, saya membuat file “r1.py & r2.py” karena saya akan mengkonfigurasi 2 router sekaligus seperti gambar map diatas.

Oke langsung ke konfigurasi Router 1 yah 🙂
Isi file “ipdevice-r1” seperi dibawah ini :

192.168.122.100 saputraaziii azi test

Lanjut isi file “konfigurasi-r1” seperti dibawah ini :

interface fastEthernet1/0
ip address 192.168.10.1 255.255.255.0
no shutdown
exit
ip dhcp pool router1
network 192.168.10.0 255.255.255.0
default-router 192.168.10.1
dns-server 8.8.8.8
exit
ip route 192.168.20.0 255.255.255.0 fastEthernet0/0

Lanjut ke isi file “r1.py” seperti dibawah ini :

from netmiko import ConnectHandler

# Containing login information such
# device type, IP, username, password even port and so on
routeres = open('ipdevice-r1', 'r')

# Store configuration file to variable
with open('konfigurasi-r1') as f:
 config = f.read().splitlines()

for router in routeres:
 router = router.split()
 router = {
 'device_type': 'cisco_ios',
 'ip': router[0],
 'username': router[1],
 'password': router[2],
 'secret': router[3]
 }

# Establish a SSH connection using login information
 # stored in login variable
 print "Connecting to %s" %router['ip']
 net = ConnectHandler(**router)

# Enter enable mode first
 net.enable()

print net.send_config_set(config)

net.disconnect()

Pada file diatas ini adalah script python yang nanti akan dijalankan.

 

Lanjut ke File untuk Router 2 seperti pada gambar map diatas

berikut isi file “ipdevice-r2” seperti dibawah ini :

192.168.122.200 saputraaziii azi test

diatas berisikan IP device, username ssh, password ssh, dan secret terminal ssh.

lanjut ke file “konigurasi-r2”  seperti dibawah ini :

interface fastEthernet1/0
ip address 192.168.20.1 255.255.255.0
no shutdown
exit
ip dhcp pool router2
network 192.168.20.0 255.255.255.0
default-router 192.168.20.1
dns-server 8.8.8.8
exit
ip route 192.168.10.0 255.255.255.0 fastEthernet0/0

Diatas berisikan tentang konfigurasi yang akan diletakan pada router 2

berikutnya yaitu isi file python yaitu “r2.py” seperti dibawah ini :

from netmiko import ConnectHandler

# Containing login information such
# device type, IP, username, password even port and so on
routeres = open('ipdevice-r2', 'r')

# Store configuration file to variable
with open('konfigurasi-r2') as f:
 config = f.read().splitlines()

for router in routeres:
 router = router.split()
 router = {
 'device_type': 'cisco_ios',
 'ip': router[0],
 'username': router[1],
 'password': router[2],
 'secret': router[3]
 }

# Establish a SSH connection using login information
 # stored in login variable
 print "Connecting to %s" %router['ip']
 net = ConnectHandler(**router)

# Enter enable mode first
 net.enable()

print net.send_config_set(config)

net.disconnect()

diatas berisikan script python yang akan kita jalankan nanti yah guys 😀

selanjutnya kita jalan script r1.py dan r2.py

lihatlah gambar dibawah ini, saat menjalankan script python nya

r2.py

r2.py

nah jika pas menjalankan script python lancar akan seperti gambat diatas ini yah guys 😀

coba cek masing-masing pc 1 dan pc 2 apakah bisa ping ke lawannya, seperti gambar dibawah ini :

nah keduanya bisa saling ping guys, berarti lab kali ini sukses hehe :D.

oke sekian dari tutorial kali ini, semoga berguna yah guys buat semua 😀

see you 🙂

Be the first to comment

Tinggalkan komentar

Alamat email Anda tidak akan dipublikasikan.


*